Issue with Chat with Brand Voice
Incident Report for CopyAI
Resolved
This incident has been resolved.
Posted Nov 27, 2023 - 22:02 UTC
Investigating
We are currently investigating this issue.
Posted Nov 27, 2023 - 21:58 UTC
This incident affected: Application.