Backend server issues
Incident Report for CopyAI
Resolved
This incident has been resolved.
Posted May 25, 2023 - 20:29 UTC
Investigating
We are experiencing some backend server issues. Our engineers are investigating!
Posted May 25, 2023 - 18:05 UTC
This incident affected: Application.